Xserve Raid - Performanceprobleme

Xserve Raid – Performanceprobleme

Xserve Raid

Wer eines der alten Apple Xserve Raids in die Finger bekommt kann mitunter nach dem ersten Start schwer enttäuscht von der Performance des Systems sein. Natürlich können die Geräte nicht mehr mit aktuelleren Raidsystemen mithalten, quälen sich aber beispielsweise weniger als 10 MB/s auf das eingerichtete Raid5, selbst wenn man vom Xserve (G5) aus über FibreChannel direkt Daten auf das Raid ablegt, stimmt vielleicht etwas mit den Controller-Einstellungen am System nicht:

Xserve Raid - Performanceprobleme

Ein paar Einstellungsänderungen lassen das Xserve Raid aber wieder mit erträglichen Schreibgeschwindigkeiten arbeiten. Hängt das Raid beispielsweise direkt an der FibreChannel-Karte eines Xserve, empfiehlt Apple die Topologie der Verbindung über den Raid Admin von »Automatisch« auf »Punkt-zu-Punkt« zu ändern. Ein weiterer Blick sollte in den Einstellungen des Raid-Admin auf den Reiter »Leistung« geworfen werden. Der folgende Screenshot zeigt zwei unterschiedliche Controller-Einstellungen, die jeweils einen Raid5-Plattenverbund ansteuern:

Links (Oberer Controller) sind die Einstellungen zu sehen, die zu der Performance auf dem Screenshot (Aja System-Test) oben führen. Also Schreibgeschwindigkeiten von weniger als 10 MB/s. Rechts (Unterer Controller) hingegen sind Controller- und Laufwerksschreibcache aktiviert, was zu einer deutlich verbesserten Schreibgeschwindigkeit (Write > 130 MB/s) des Systems führt:

Xserve Raid - Performanceprobleme

Damit lässt sich durchaus noch etwas anfangen und das gute alte Xserve Raid kann beispielsweise noch eine zeitlang als Backup-Server oder ähnliches herhalten. Selbst wenn das Vertrauensverhältnis schon des öfteren gelitten hat.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.