Der Steinbock holpert noch

Nachdem durch meine eigene Schusseligkeit der Steinbock einen schlechten Start auf dem Macbook Pro hatte, ging die Installation mit einer geprüften CD dann auch schnell und ohne Probleme vonstatten. Da die 64bit-Architektur ja immer ausgereifter ist, habe ich diesmal gleich zur AMD64-Version von Intrepid gegriffen.

Nach dem ersten Start musste erst noch ein GPT-Sync durchgeführt werden und OS X einmal gestartet werden (fragt mich nicht, warum), bevor der Steinbock zum Leben erweckt werden konnte. Die grundlegende Hardware muss nicht mehr eingerichtet werden, es funktioniert alles out-of-the-box. Trotzdem gilt das erste Augenmerk der Hardware. Der Nvidia-Treiber ist aus bekannten Gründen nicht aktiviert, pommed für die kleinen Extrafeatures des Macbook Pro ist auch nicht dabei und der Synaptics-Treiber für das Touchpad ist ebenfalls nicht aktiv. Letzterer ließ sich nur durch einen manuellen Eingriff in die mittlerweile ziemlich dünne xorg.conf akivieren.

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "VertScrollDelta" "20"
Option "HorizScrollDelta" "350"
Option "VertTwoFingerScroll" "true"
Option "HorizTwoFingerScroll" "true"
Option "FastTaps" "false"
Option "TapButton2" "3"
Option "AccelFactor" "0.3"
Option "SHMConfig" "on"
EndSection
Section "Monitor"
Identifier "Configured Monitor"
EndSection
Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
EndSection
Section "Module"
Load "glx"
Disable "dri2"
EndSection
Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection
Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
Inputdevice "Synaptics Touchpad"
EndSection

So sieht sie nun aus, wobei die Optionen, abgesehen von der SendCoreEvents-Option, in der Touchpad-Sektion wahrscheinlich auch noch wegfallen könnten, da sie ja inzwischen mit gsynaptics oder ähnlichen grafischen Tools eingestellt werden können. Derart ausgestattet kann es an die fehlenden Programme gehen. Es ist alles da und läuft auch, das Wiederherstellen der gewohnten Arbeitsumgebung ist ziemlich unspektakulär. Viel eher ist es eine Zeitfrage, ich habe mich heute mal auf das Wesentliche konzentriert, also Mail, Chat und Internetkram. Der Rest kommt dann die Tage dran.

Auffällig ist, dass die Netzwerkverbindung unter hohen Belastungen ab und zu unvermittelt wegbricht, ohne eine Fehlermeldung zu erzeugen. Das passiert sowohl im WLAN (Airport), das mittlerweile von ath9k getrieben wird, als auch bei angeschlossenem Kabel. Auch war nach einem Neustart der Sound auf einmal stummgeschaltet, wobei ich mich nicht erinnere, dies selbst getan zu haben. Mein vorläufiger Eindruck ist, dass man mit dem Steinbock leben kann, allerdings ist auch noch einiges zu tun.

  1. Pingback: Ubuntu@MacVillage » Neue Konfiguration, alte Wirkung

  2. Pingback: Kleine Technik › Macbook Toupad: Unter Linux volle Funktion

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.